Technical Support

Splitting Files

There are many reasons why you might want to split up your data file. Perhaps you are working with a distant relative on one branch of your family and don't really need to overwhelm them with information on your spouse's family. Perhaps you have two Family Files and only want to copy a couple of individuals between them. Whatever the reason, Family Tree Maker offers three methods for splitting your data, so you can customize this feature for your needs. One makes use of the Custom report, another the Kinship report, and the third method uses the Ancestor, Descendant, or Outline Descendant Trees. If you use Family Tree Maker version 6.0 or higher for Windows, you can also split a file using the All-in-One Tree.

Exporting Individuals from the Custom Report

  1. Start Family Tree Maker and open your Family File -- the file that contains the individuals you want to export.

  2. From the View menu, select Report.

  3. From the Format menu, select Report Format, then select Custom Report from the list of available items.

The Report Format dialog box
Figure 1: The Report Format dialog box

  1. Click OK.

    Family Tree Maker formats the report and displays a list of individuals in your file, as well as their birth and death dates.

  2. Next, you need to specify the branch or group of individuals you want to export to the new file. From the Contents menu, select Individuals to Include. Family Tree Maker displays the Include dialog box and gives you two choices: All Individuals or Selected Individuals.

    The All Individuals selection is exactly what it sounds like; it includes everyone in your Family File. However, since your intention is to split off a branch, click Selected Individuals, then click Individuals to Include to specify the group.

    Family Tree Maker displays the Individuals to Include dialog box.

The Individuals to Include dialog box
Figure 2: The Individuals to Include dialog box

  1. First, click the << button. This removes anyone from the right window that you might have included in previous reports.

  2. Next choose all of the individuals that you want to include in your new file. To include people one-by-one, click each individual in the list of Available individuals, then press the > button to include them -- this moves the individual to the list on the right and includes them in the report. If you want to include the ancestors or descendants of a given person, select that person in the list of Available individuals, then press the Ancestors> or Descendants> button. To select all individuals that meet a certain criteria, click the Find> button.

    Suppose you want to include all individuals who were born in San Francisco. Click the Find> button.

    Family Tree Maker displays the Add Individuals dialog box.

    Click the Search drop-down list and select Birth Location. Then in the blank for field, type San Francisco. Click OK to process the search. Family Tree Maker returns you to the Individuals to Include dialog box. Notice that the list of included individuals on the right is filled with the individuals that meet your search criteria. Click OK again to return the report.

    Note: You may be wondering how to specify the types of data to export for each person. Although the report only includes the birth and death dates on screen, Family Tree Maker automatically exports all of the information associated with each individual: dates, locations, facts, notes, marriage status, scrapbook pictures, etc.

  1. The final step in this process is to create a new file that includes these individuals. From the File menu, select Copy/Export Individuals in Report.

    Family Tree Maker displays the Copy/Export Individuals dialog box.

The Copy/Export Individuals in Report dialog box
Figure 4: The Copy/Export Individuals dialog box

    Note: There are two Copy/Export commands in the File menu. Be sure to select the second one in the list. If you select Copy/Export Family File by mistake, it copies your entire Family File, not the selected individuals.

  1. Click the Save in drop-down list and select the drive where you want to save the new file.

    A list of files and folders on this drive appears in the box below the Save in field. If you want to save the file in a folder on the specified drive, double-click that folder. For example, suppose you want to save the file in Family Tree Maker's working directory -- usually C:\FTW. Click the Save in drop-down list and choose your (C:) drive, then double-click the FTW folder that appears in the box below.

  2. Enter a name for the new file in the File name field, then click Save. The resulting file includes just those individuals you included in the report.

Exporting Individuals from the Kinship Report

Note: You must have version 4.0b or higher to export individuals from a Kinship report. Users of 4.0 and 4.0a can can download the free 4.0b update.
  1. Start Family Tree Maker and open your Family File -- the file that contains the individuals you want to export.

  2. Specify the individual whose kinship you want to display. From the the View menu, select Index of Individuals.

    Family Tree Maker displays a list of individuals in your Family File.

  3. Select the appropriate person, then click OK.

  4. From the View menu, select Kinship.

    Family Tree Maker displays the Kinship report.

  5. From the File menu, select Copy/Export Individuals....

    Family Tree Maker displays the Copy/Export Individuals dialog box.

  1. Click the Save in drop-down list and select the drive where you want to save the new file.

    A list of files and folders on this drive appears in the box below the Save in field. If you want to save the file in a folder on the specified drive, double-click that folder. For example, suppose you want to save the file in Family Tree Maker's working directory -- usually C:\FTW. Click the Save in drop-down list and choose your (C:) drive, then double-click the FTW folder that appears in the box below.

  2. Enter a name for the new file in the File name field, then click Save.

    The resulting file includes just those individuals you included in the Kinship report.

    Tip: If the Kinship report doesn't include all of the individuals you want to export, use the Custom report described earlier in this document. With the Custom report, you have a lot more freedom -- you can specify individuals one at a time or in groups.

Exporting Individuals from Ancestor, Descendant, All-in-One, or Outline Descendant Trees

This method is simpler, as it merely consists of creating a tree from the individual at the top or bottom of the branch you want to split off.
  1. Start Family Tree Maker and open your Family File -- the file that contains the individuals you want to export.

  2. Specify the individual whose tree you want to display. From the the View menu, select Index of Individuals.

    Family Tree Maker displays a list of individuals in your Family File.

  3. Select the appropriate person, then click OK.

  4. From the View menu, select Ancestor Tree.

    Note: If you want to export individuals from a Descendant tree, select either Descendant Tree or Outline Descendant Tree from the menu that appears.

  5. Customize the tree to include the number of generations you prefer.

    Suppose you want to include six generations. From the Contents menu, select # of generations to show. Use the up and down arrows to set the number in the Select the number of generations to show field or simply type 6 into the field.

The # of Generations to Show dialog box
Figure 6: Selecting the number of generations to show

  1. Click OK to return to the tree.

    Note: You may be wondering how to specify the types of data to export for each person. Family Tree Maker automatically exports all of the information associated with each individual: dates, locations, facts, notes, marriage status, scrapbook pictures, etc.

  2. From the File menu, select Copy/Export Individuals in Ancestor Tree.

    Note: The Copy/Export Individuals selection will read Copy/Export Individuals in (Ancestor, Descendant, or Outline Descendant) Tree -- depending on which one you're working with.

    Family Tree Maker displays the Copy/Export Individuals dialog box.

  1. Click the Save in drop-down list and select the drive where you want to save the new file.

    A list of files and folders on this drive appears in the box below the Save in field. If you want to save the file in a folder on the specified drive, double-click that folder. For example, suppose you want to save the file in Family Tree Maker's working directory -- usually C:\FTW. Click the Save in drop-down list and choose your (C:) drive, then double-click the FTW folder that appears in the box below.

  2. Enter a name for the new file in the File name field, then click Save.

    Tip: If the tree doesn't include all of the individuals you want to export, use the Custom report described earlier in this document. With the Custom report, you have a lot more freedom -- you can specify individuals one at a time or in groups.

All of these methods offer the flexibility of splitting your Family File into smaller files. Imagine you started researching a family and got sidetracked; suddenly you have a large, unwieldy file. These methods can be used in combination with other commands to split your Family File into two pieces. Or perhaps you want to share a branch with a distant relative or submit a portion of your Family File to the World Family Tree Project. Whatever the reason, this feature is truly a time saver.

Back to the Knowledge Base | Back to the Online Help Center

Home | Help | About Us | Biography.com | HistoryChannel.com | Site Index | Terms of Service | PRIVACY
© 2009 Ancestry.com