Technical Support

Merging Files

Suppose a friend or relative sends you a file that contains information you'd like to add to your tree. Maybe they send you a file that contains a new branch, or some detailed information about one of your relatives. With Family Tree Maker, you don't have to enter the information by hand -- you can combine files, merge the duplicates, and link the new lines together. The following instructions will guide you step-by-step through the merge process.

Caution: Before you merge files or make any modifications to your database, be sure to backup your Family File. This way if you make a mistake, you can restore the backup and revert to the original. To backup your Family File, from the File menu, select Backup Family File. You can backup to floppy disk(s) or a folder on your hard drive.

Note: By default, Family Tree Maker adds an automatic source-citation to every piece of information merged from one file into another,. This is designed to help you kep track of where this data has come from. The Master Source that is created is the name of the file you are merging. The citation information is the date the file is merged. If you prefer not to have Family Tree Maker create this source-citation, follow these steps:

  1. Start Family Tree Maker
  2. From the Help menu choose System Information
  3. Press the down arrow button at the end of the Run line and select FTW.INI
  4. In the [Options] section, remove the semicolon from the beginning of the line that says:
    WFTAddSources=FALSE
    of, if your [Options] section does not have that line, add it
  5. Save and exit the FTW.INI file and restart Family Tree Maker in order for this change to take effect

Merging Files

To merge two files:

  1. Start Family Tree Maker and open the destination file. This is the file you ordinarily work with, the file that's going to receive the new information.

  2. From the File menu, select Append/Merge Family File.
    Select Open Family File instead if you are using version 4.4 or earlier

    Family Tree Maker displays the Append Family File dialog box.

The Open Family File dialog box
Figure 1: The Append Family File dialog box

  1. In the Look in field, select the drive and directory that contains the source file. This is the file your friend or relative sent, the file that contains the information you'd like to merge with your current database.

  2. Click the Files of type drop-down list and select the type of file you're importing.

To open a... Select...
Family Tree Maker for Windows file Family Tree Maker for Windows (*.FTW)
Family Tree Maker for DOS file Family Tree Maker for DOS (*.FTM)
Backup Family Tree Maker file Family Tree Maker Backup (*.FBK)
File from another genealogy software
program that supports GEDCOM
GEDCOM (*.GED)
PAF files from PAF version 2.1 or later
(not including version 3.x)
Personal Ancestral File (INDIV2.DAT)
Any type of file that Family Tree Maker
can read
Family Tree Maker
(*.FTW, *.FTM, *.FBK, *.FBC, *.GED)

  1. In the box above the File name field, click the source file once to select it, and then click Append File.

  2. Family Tree Maker displays a dialog box reminding you to back up your file as a safety measure before you continue. If you have done so, click OK and continue with the next step. If not, click Cancel, back up your file, then go back to step one.

    Family Tree Maker displays the Individuals to Include dialog box.

The Individuals to Include dialog box
Figure 2: The Individuals to Include dialog box

  1. Here you can choose whether you want to merge all individuals in the source file or just selected ones. To select all individuals in the source file, click the >> button. To include people one-by-one, click each individual in the list of Available individuals, and then click the > button to include them. If you want to include the ancestors or descendants of a given person, select the person in the list of Available individuals, and then click the Ancestors> or Descendants> button. To include individuals that fit a certain criteria (for example, all individuals that were born in San Francisco), click the Find> button.

    If the source file does not contain any individuals that seem to match the individuals in your file, you receive a message informing you of this fact. Click OK to continue with the process.

    Family Tree Maker displays the Append File dialog box.

The Append File dialog box
Figure 3: The Append File dialog box

  1. If you wish to display a merge report before continuing, click Display merge report. Use the scroll bars to view the report or click Print to print a paper copy of it. The merge report lists all individuals in both files (source and destination) that are potential duplicates.

    Note: You should print the report and use it to help clean up the resulting file and appropriately link the newly-imported individuals to your family tree, especially if you choose not to merge duplicate individuals at this time.

    When you are done viewing the report, click Done to return to the Append File dialog box.

  2. If no matching individuals were detected (or if you do not wish to merge matching individuals at this time), click Append only (no merge). All selected individuals from the source file will be added to your file as new, separate entries.

    If matching individuals were detected, you should merge them to avoid duplicate entries. Start the merge process by clicking Merge matching individuals.

    Note: Be sure to check your file for duplicates even after the merge process is complete (this is where the merge report can come in handy). There should be only one instance of each individual in your file -- duplicate entries can lead to incomplete trees, reports, and other complications.

  3. If you have not yet viewed the merge report, you will be prompted to view it again. Click No to proceed with the process.

    Family Tree Maker starts merging. If it finds exact matches, it will merge them without further prompting. The program only merges individuals automatically if they have the same name and birth date. If Family Tree Maker finds individuals that seem to match but some of the available information differs, it displays the Merge Individuals dialog box.

  1. Family Tree Maker automatically imports all of the information from the source file. If there is conflicting information, such as different birth dates for the same individual, Family Tree Maker will import both pieces of data as alternate facts.

    Note: Family Tree Maker allows you to record and display conflicting information until you can confirm which is correct by later research. For example, suppose there are two possible birth dates for the same individual, and you won't know which one is correct until you verify the sources. In Family Tree Maker 5.0, you can record both birth dates until you have time to do more research. (See the Alternate Facts tutorial for more information.)

    There are a few facts which do not store alternates: Name, AKA, Medical Information, Sex, Cause of Death, Title, Address and Phone, and in some cases Marriage Beginning Status and Marriage Ending Status. Carefully compare the information displayed for each data field, then click the option buttons next to the information that you want to keep. The information that isn't chosen will be discarded. If both individuals contain Notes, Family Tree Maker appends the Notes from the merged individual to the end of primary individual's Notes section. You don't have to retype a word.

  2. Once you have made your selections, click Merge to merge the individuals. If you decide that these two individuals are not duplicates or you do not want to merge them at this time, click Don't merge.

    The program will prompt you to repeat steps 11 and 12 as often as necessary until all possible duplicates are merged.

  3. When you have merged the last individual, Family Tree Maker displays a dialog box informing you that the process is complete. Click OK.

  4. Family Tree Maker displays the merge report. Use the scroll bars to view the report or click Print to print a paper copy of it. When you are done viewing the report, click Done.

  5. This concludes the merge process. Family Tree Maker displays a dialog box prompting you to examine your file closely to assure that you accomplished the desired results. Click OK.

    Important: After completing the merge process, you can always undo the entire process and restore your file to the way it was before you started merging as long as you have not exited the program yet. Once you exit the program after merging, the changes become permanent and the only way to restore your file to its original state is to restore the backup file. To undo the merge, from the Edit menu, select Undo Merge Individuals.

Creating the Alternate Facts Report

Once you have merged files, chances are that some of the individuals in your file will have conflicting information. Should you ever want to review all of the facts in your Family File that contain alternate data (such as different birth dates), you can generate an Alternate Facts report. Then you can take your time working through this report and selecting which facts to keep and delete, even choosing to keep both instances of them until you verify which is correct.

To create an Alternate Facts report:

  1. From the View menu, select Report.
  2. From the Format menu, select Report Format.
  3. Select Alternate Facts, then click OK.
Family Tree Maker generates the report and displays it on screen.

The Alternate Facts report
Figure 5: The Alternate Facts report

This report can come in handy. Suppose that you've done some more research and have discovered that some of the alternates you entered previously are now invalid (i.e. you've found sources to support one birth date but not another). The Alternate Facts report gives you a quick way to identify the facts in question. The report can also act a sort of road map for further research. Take it with you while researching. It's a quick way to find out which facts still need to be documented.

Back to the Knowledge Base | Back to the Online Help Center

Home | Help | About Us | Biography.com | HistoryChannel.com | Site Index | Terms of Service | PRIVACY
© 2009 Ancestry.com