Technical Support

Repairing a Damaged File

A damaged file or data corruption can often result in the occurrence of a number of program errors. Most often the "bad" data is brought into a family file through merging unchecked files, improper shut-downs of Family Tree Maker or Windows, a virus or through other existing damaged files. If this file was damaged as a result of Family Tree Maker, the company assumes the responsibility to fix this error without charging a fee. With this in mind, Family Tree Maker 4.4, 5.0 and 6.0 has the ability to correct many problems that a customer might experience. With version 4.4, please download an update for this utility from: familytreemaker.genealogy.com/filefixer.html

The Technical Support Department has outlined several steps for you to fix a damaged file. If after completing all five steps and you find the file has not been corrected, please see step six for sending in damaged files.

Steps for Repairing a Damaged File

Try using your family file after completing each of the following tips to see if your file now works.
  1. Compress File:

    Hold down the following three keys to compress your database:

    CTRL + ALT + C

  2. Re-Indexing Files

    Hold down the following four keys to re-index your database:

    CTRL + ALT + SHIFT + BACKSPACE

  3. File Fixer:

    1. Start the Family Tree Maker program.

    2. Hold down the following 4 keys in succession (so at the end of this you will have 4 keys held down): Alt + Ctrl + Shift + Left Arrow ( This is the arrow pointing to the "left" on your arrow keypad). These keystrokes will bring up a box that says "Family File Checker with File Fixer".

    3. To start the File Fixer, click on the Start button in the lower right corner of this box. If errors are found, a new dialog will ask if you want to run the Auto File Fixer. Click Yes to do so (clicking No will run the file through a normal error check but will not attempt to fix any errors it finds).

    4. If you encounter any damaged file messages while the File Fixer is checking your file, click OK, since this should allow the File Fixer to recover and continue checking for errors.

      Note: Depending on the number of errors the program finds, you may find yourself clicking OK or Ignore quite a few times. This is normal on a file with many errors, so continue clicking OK and Ignore.

    5. Once the error checking is complete, a dialog box will ask you to specify a name for the log that will list the individuals removed or excluded from the new file (the File Fixer may not have to remove any individuals). It will default to the directory to which Family Tree Maker is installed. You can change the path that is listed to the directory you want. You must give this log a name so you know where to look to find who was removed. After the path, click your mouse to insert the writing cursor and type a file name in and a ".txt" extension (example: C:\FTW\log.txt). Please keep in mind that this log is a text file and should have the extension ".txt." Any word processing program or text editor such as Windows Notepad can be used to open this file.

    6. Another dialog box will ask you to supply a name for your new Family File. It is very important to remember that once this process is finished, work only with this newly created Family File. If you mistakenly work with your original file, your information will be put into the original damaged file. It is important that you keep careful track of what you named this new file and where it is. You will want to supply the full path and .FTW file extension. We suggest you name the file the same name as your original file but with the number "1" right before the .ftw extension to distinguish between your old and new Family Files. Example of a new Family File: C:\FTW\Johnson1.ftw

    7. The File Fixer will create a new FTW file with the name you gave it. Your next step would be to open this new file. First close the box on your screen by clicking OK. Then go to File, and Open Family File. Find the new file you just created and double-click it to open. It is recommended that you check this file as well to be sure that all errors were cleared. Follow step 2, but when you get to step 3, click No to bypass the Auto Fixer (Step 3 tells you to hit Yes). If you do find more errors, you can run the Auto File Fixer on this new file by running through Steps 3-6 exactly as you did before. Do not be alarmed if there are still errors - occasionally one has to run through several files to clear out all of the errors.

  4. Exporting Individuals:

    1. Click on the Report button.

    2. Choose Report Format from the Format menu and make sure that Custom is selected.

    3. Choose Individuals to Include from the Contents menu. Make sure the dot is on All Individuals.

    4. Choose Copy/Export Individuals in Report from the File menu.

      Note: Choose the second instance of Copy/Export.

    5. Type in a new name for your file. Click on the Save button.

      Example of a new Family File: C:\FTW\Johnson1.ftw

    6. Choose Open Family File from the File menu. Click on the new name you chose.

    7. Click the Open button.

    If you are unable to create a report, try the following and then repeat steps 1-7 from the above procedure:

    1. Exit Family Tree Maker.

    2. Use Notepad to edit the FTW.INI file which is located in the same directory that you installed Family Tree Maker (usually C:\FTW).

    3. If the following line is present:

      ;DeleteStyles=TRUE

    4. Remove the semicolon ";".

    5. If the Delete Styles line is not present add this line to the end of the [Options] section: DeleteStyles=TRUE

    6. Exit Notepad, saving your changes.

    7. Restart Family Tree Maker and try the Report.

    8. Go back to the FTW.INI and replace the semicolon (;) at the beginning of the DeleteStyles=TRUE line you added.

  5. Exporting To GEDCOM:

    Note: This procedure will destroy any links to scrapbook items that you have created. All pictures and other scrapbook items will have to be re-entered at a later date.

    If you are using Windows 3.1, follow the instructions to first Export to GEDCOM and then Import a GEDCOM file.

    If you are using Windows 95/98, follow the instructions to Export to GEDCOM and then Import a GEDCOM file.

    Use Only if None of the Above Helps

  6. Submitting your damaged File

    Steps 1 through 5 have covered almost everything that can be done to fix a damaged file. If you decide to send in your file to the Technical Support Department for further assistance please include the following information with your file:

    1. Name
    2. Address
    3. Phone Number
    4. Email Address
    5. Version of Family Tree Maker
    6. What steps you have taken and what are the results from each step
    7. Name of the Technical Support Representative who has been helping you

Back to the Knowledge Base | Back to the Online Help Center

Home | Help | About Us | Biography.com | HistoryChannel.com | Site Index | Terms of Service | PRIVACY
© 2009 Ancestry.com